Все технические форумы на одном сайте Удобный поиск информации с популярных форумов в одном месте
Вопрос: Почитать текст письма

Добрый вечер! Встала задача получить письмо. Письмо я получил а вот текст письма выдает в HTML формате, может есть другой способ получить текст письма не в формате HTML, подскажите кто сталкивался с этим.

<html>
<head>
<meta http-equiv="content-type" content="text/html; charset=utf-8">
</head>
<body text="#000000" bgcolor="#FFFFFF">
ТУТ ТЕКСТ
</body>
</html>


Вот мой код

1C
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
Процедура ПолучениеИнтернетПочты()
    
    //ПочтовыйАдресОбмена="******@karelgaz.ru";
    POP3Сервер="192.168.2.50";
    ПортСервераPOP3Рассылки=110;
    Пользователь="*******@mail.ru";
    Пароль="******";
    
    Профиль = новый ИнтернетПочтовыйПрофиль;
    Профиль.АдресСервераPOP3 = POP3Сервер;  
    Профиль.Пользователь = Пользователь;
    Профиль.Пароль = Пароль;
    Профиль.ПортPOP3 = ПортСервераPOP3Рассылки;
    //ПРофиль.АутентификацияPOP3 = СпособPOP3Аутентификации.Обычная;
    
    Попытка
        Предупреждение("Попытка подключения к серверу почты "+Профиль.АдресСервераPOP3);
        Состояние("Подключение к серверу "+Профиль.АдресСервераPOP3);
        Почта = Новый ИнтернетПочта;
        Почта.Подключиться(Профиль);
        
        МассивСообщений = Новый Массив;
        Предупреждение("Чтение почтовых сообщений");
        Состояние("Чтение почтовых сообщений...");
        МассивСообщений = Почта.Выбрать(Истина); // ЛОжь - письма с сервера не удаляются...
    Исключение
        Предупреждение("Ошибка подключения к серверу ","Остановить");
        Предупреждение(""+ОписаниеОшибки(),"Остановить");
        Сообщить("Ошибка подключения к серверу!");
        Сообщить(""+ОписаниеОшибки());
        Возврат;
    КонецПопытки;
    
    Если МассивСообщений.Количество() = 0 Тогда
        Предупреждение("В почтовом ящике нет сообщений. Прерываем работу.");
        Сообщить("Почтовый ящик пуст");
        ПолученныеПисьма.Очистить();
        Возврат;
    КонецЕсли;
    ОтобразитьПочтовыеПисьма(МассивСообщений);  
КонецПроцедуры
1C
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
Процедура ОтобразитьПочтовыеПисьма(МассивСообщений)
    ПолученныеПисьма.Очистить();
    Если МассивСообщений.Количество() = 0 Тогда
        Возврат; // почтовых сообщений нету.
    КонецЕсли;
    
    Предупреждение("Начало отображения сообщений в обработке");
    МассивСообщенийОбмена = новый Массив;
    
    ИмяФайлаСообщения = "";
    ПолученныеПисьма.Очистить();
    Для Индекс = 0 По МассивСообщений.Количество() - 1 Цикл
        стр = ПолученныеПисьма.Добавить();
        стр.ДатаОтправления = МассивСообщений[Индекс].ДатаОтправления;
        стр.Индекс = Индекс;
        Стр.ОтКого=МассивСообщений[Индекс].Отправитель.Адрес;
        Стр.ДатаПолучения=МассивСообщений[Индекс].ДатаПолучения;
        стр.Тема = МассивСообщений[Индекс].Тема;
        Для Каждого Вложение из МассивСообщений[Индекс].Вложения Цикл
            Стр.ФайлВложения=Вложение.ИмяФайла;
            Вложение.Данные.Записать("c:\Почта"+Вложение.ИмяФайла);
        КонецЦикла;
        Для Каждого Текст из МассивСообщений[Индекс].Тексты Цикл
            Стр.ТекстПисьма=Текст.Текст;
            Текст.Данные.Записать("c:\Почта\ТекстСообщения.txt");
        КонецЦикла;
    КонецЦикла;
 
    Предупреждение("Сообщения отображены и удалены с сервера");
КонецПроцедуры
Ответ: Ermak27, блин, у тебя ведь обычные формы.

Тогда юзай ПолеHTMLДрокумента
Вопрос: Отправка электронной почты в формате html

Добрый день!

Мы из 8ки отправляем электронные письма, в тело письма вставляем html текст с определенными настройками CSS, но при получении адресатом такого письма никакие настройки не работают. В чем может быть причина?
Платформа 8.3.13.1926
Конфигурация документооборот 2.1.10.2
Ответ: "формат для интернета" - кажется оно
Вопрос: Отправка почты через CDO в HTML формате, откуда пробелы??

Пользовал эту методу для отправки почты успешно до тех пор, пока не стал отправлять письма в HTML формате. Странным образом, после сборки письма добавляется пробел через каждые то ли 997, то ли 998 символов в тело письма... Причем он виден только получателю...  в итоге - все накрывается медным тазом, т.к., например, пробел в ссылке не допустим... что за ерунда?
Ответ: () А почему 9 не хочешь использовать?
Вопрос: УТ11 Отправка писем через mail.ru

Уважаемые специалисты, посоветуйте пожалуйста, как исправить проблему при отправке через встроенный почтовый клиент в УТ11.3.4.124, 1С8.3.10.2466.

Служебная почтовая запись - привязана к mail.ru, отправку надо делать так, чтобы в веб-клиенте, в отправленных появлялось отправленное письмо.

Сама проблема - письмо появляется, но со временем, отличающимся от нужного на 3 часа. Грешил на ошибку настройки времени сервера - но на нём все верно (UTC+4), проверил соседний компьютер - с него отправляется с таким же смещением.
Ответ: Посмотрел полученное письмо - в первом заголовке все тоже выглядит правильно:

Received: by smtp58.i.mail.ru with esmtpa (envelope-from <*****@mail.ru>) id 1ePQB1-0003h5-Mj for *****@gmail.com; Thu, 14 Dec 2017 12:51:39 +0300
Date: Thu, 14 Dec 2017 13:50:51 +0400
Вопрос: Отправку писем с периодичностью

Добрый день! Я отправляю письма с помощью этого кода
1C
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
    ОчиститьСообщения();
    
    Профиль = Новый ИнтернетПочтовыйПрофиль;
    
    АдресО                       = "*********";
    Пароль                       = "*********";
    АдресСервера                 = "smtp.gmail.com";    
    Профиль.АдресСервераSMTP     = АдресСервера; 
    Профиль.ПортSMTP             = 465;
    Профиль.Пользователь         = АдресО;
    Профиль.Пароль               = Пароль;
    Профиль.АутентификацияSMTP   = СпособSMTPАутентификации.ПоУмолчанию;
    Профиль.ИспользоватьSSLSMTP  = Истина;
    Профиль.ПарольSMTP           = Пароль;
    Профиль.ПользовательSMTP     = АдресО; 
    
    Почта = Новый ИнтернетПочта;
    Попытка
        Почта.Подключиться(Профиль);
    Исключение
        Сообщить("Ошибка при подключении к серверу" + ОписаниеОшибки());
        Возврат;
    КонецПопытки;
    
    Для Каждого Стр из ТабличнаяЧасть1 Цикл
        АдресП = Стр.mail;
        Если АдресП="Нет данных" Тогда
            Продолжить;
        КонецЕсли;      
        Сообщение = Новый ИнтернетПочтовоеСообщение;
        Сообщение.Отправитель = АдресО;
        Сообщение.Получатели.Добавить(АдресП);
        Сообщение.Тема = ТемаПисьма;
        Сообщение.Тексты.Добавить(Текст,ТипТекстаПочтовогоСообщения.HTML);
        Состояние("Идет отправка посты на адрес: "+АдресП); 
        Почта.Послать(Сообщение);
        Сообщить("Почта отправлена: "+ АдресП);
    КонецЦикла;
    Почта.Отключиться();
Можете подсказать как сделать чтобы отправлять по 20 писем через 1 минуту?
Спасибо
Ответ:

Не по теме:

Dethmontt, почему не получат? Здесь же условие по индексу и количеству строк ТЧ прописано, 20 здесь ни о чем:

1C
1
2
3
4
Для к = 1 по 20 Цикл
        Если Индекс <= ТабличнаяЧасть1.Количество()-1 Тогда
            //отправляем письма, адрес = ТабличнаяЧасть1[Индекс].mail
            Индекс = Индекс + 1;
Вызов процедуры будет происходить как раз до полной отправки всем адресатам, только потом отключаем обработчик ожидания.



Добавлено через 6 минут
Внесла коррективы:
1C
1
Индекс = Индекс + 1;
Но думаю, Денис все равно не об этом)
Вопрос: ТабДок в html-письмо по электронной почте

Всем привет. Необходимо отправлять данные из табличного документа на электронную почту не в виде вложения, а в виде html-документа. Делаю это следующим образом:

Код:
//вступительная часть по настройке "ИнтернетПочтовыйПрофиль"

    Письмо = Новый ИнтернетПочтовоеСообщение;
    ПутьHTML = ПолучитьИмяВременногоФайла("html");
    Объект.ТабДок.Записать(ПутьHTML, ТипФайлаТабличногоДокумента.HTML);
    HtmlДок = Новый ЧтениеТекста;
    HtmlДок.Открыть(ПутьHTML);
    ТекстHtmlДока = HtmlДок.Прочитать();
    Текст = Письмо.Тексты.Добавить(ТекстHtmlДока,ТипТекстаПочтовогоСообщения.HTML);

//Заключительная часть по отправке письма
Письмо отправляет нормально, но полностью пропадает форматирование (шрифты и границы таблиц).
Если проанализировать получаемый файл, то получается, что при формировании текста письма пропадают настройки CSS, которые записываются перед <head> и <body>. Сам файл записывается нормально. И если в ТипФайлаТабличногоДокумента использовать не HTML, а HTML3, то сохраняется форматирование текста, но не ячеек таблицы. Кто-нибудь знает, как можно решить проблему?
Ответ:
Если методом КопиПаста (из табдока в html), то встает нормально (вообще без использования SSL), но надо это делать автоматически. Получается, что выход только - при формировании отчета параллельно автоматически генерировать html-код. Придется повозиться .
Вопрос: Отправка 1с писем через прокси

есть корпоративная почта, которая доступно через прокси сервер, надо настроить отправку из 1с обычные формы отправку счетов с этой почты.
То есть сейчас они заходят через веб браузер, в котором прописана прокся, на веб морду почтового сервера и отправлют. А надо то же самоесделать из 1с.
Есть какие-то варианты как это сделать? насколько я знаю, штатно 1с умеет проксировать только http соединения.
Ответ: 3proxy умеет прокидывать pop3 и smtp, но я не уверен, что ТС нужно именно это.
Вопрос: Универсальный формат обмена версии 1.0 больше не поддерживается БП

Всем привет!
Надеюсь на советы гуру обменов, у меня мысли и идеи уже кончились...
Что мы имеем:
УТ 11.1.10.180 - сильно доработана;
БП 3.0.52.39 - типовая.
Между базами настроен обмен через универсальный формат (1.0), и все это прекрасно рабо на протяжении где то трех лет. И тут в новом обновлении БП выясняется что формат обмена 1.0 больше не поддерживается, следовательно обмен больше не работает.
Пробовал советы из этой темы:
Но в релизе 11.1.10.180, формат 1.2 еще не поддерживается.
Пробовал из типовых УТ переносить модель менеджера обмена, план обмена в текущую ут, ошибок куча, ничего не работает. Думал уже БП снять с поддержки и обновить так, чтобы остался формат 1.0, так же ошибок море.
Вопрос, может кто сталкивался с такими ситуациями, как быстро и грамотно восстановить обмен?
Ответ:
Проверил новые и старые правила УТ11-БП3. То что написано в предыдущем посте половину выкидываем из головы или не читаем. Последний вариант рабочий и правильный и получится сделать все быстро.
Мой вам совет не вникать в новые правила и не пытаться их подстроить под ваши старые УТшки 11.1-11.2. Гораздо проще под новый формат поправить старые правила, которые работали. Во многих ПКО отличия лишь в том что в новом формате практически везде добавилось поле "Ссылка".
Вопрос: Доработка обмена Универсальный формат. Как отказаться от загрузки объекта?

Доброго времени суток! Сражаюсь с обменом через универсальный формат между УТ 11.2 и БП 3.0. В принципе, кое-что мне удалось сделать на стороне БП, внеся измерения в модуль МенеджерОбменаЧерезУниверсальныйФормат13.
Внес изменения в процедуру "ПКО_Документ_РеализацияТоваровУслуг_ПриКонвертацииДанныхXDTO" тем самым получив некоторые доп. опции при загрузке Расходных накладных.
Но также есть задача, при получении расходной накладной, проанализировать её и в некоторых случаях отказаться от загрузки конкретной накладной. Фактически, мне нужен аналог "Отказ = Истина", который был в "ПослеЗагрузкиОбъекта" в старой доброй конвертации 2.
Подскажите пожалуйста кто знает, как это сделать грамотно?
Ответ: () спасибо за ценные комментарии. Учту! Действительно, поспешил я со снятием с поддержки, не знал о такой возможности. Придется возвращать. Думал, предполагается делать доработку модуля через расширение конфигураций, но текущая БП 3.0 пока работает в режиме совместимости и хрен там модуль заменишь. Но теперь все понятно!
Вопрос: Как работать с Поле HTML Документа?

Подскажите как можно реализовать следующие действия или дайте ссылочку на материал.
Есть необходимость программно заполнить поля на форме сайта, авторизироваться и проводить программно следующее заполнение полей на сайте.
???

Добавлено через 5 часов 9 минут
Нужно программно заполнить input'ы и нажать кнопку..

Добавлено через 16 часов 29 минут
Как заполнить поля разобрался. Есть идеи как по кнопке кликнуть?

Добавлено через 1 час 17 минут
Во всем разобрался. Тему можно закрыть/удалить )
Ответ: Через ком. Сейчас времени нет. Во второй половине дня или вечером отпишусь.