Все технические форумы на одном сайте Удобный поиск информации с популярных форумов в одном месте
Вопрос: ошибки с регламентным заданием

добрый вечер.написал регламентное задание по обработке заказа.но оно ругается на ошибки.то "Предупреждение" в модуле объекта не нравиться-заменил на сообщить то "ПользователиИнформационнойБазы.ТекущийПользователь().ОсновнойИнтерфейс.Имя" на имя ругается,то на рабочую дату(заменил на текущую()) а вот имя менять не знаю стоит ли дальше будет на что то ругаться.как правильно сделать?
Ответ: Регламентные задания вызываются на сервере, а не на клиенте.

В синтакс-помощнике описаны, какие процедуры доступны в каких местах.

Например предупреждение нельзя вызвать на сервере:
Предупреждение (DoMessageBox)
...
Доступность:
Тонкий клиент, веб-клиент, толстый клиент, мобильное приложение(клиент).

Проверка модуля сразу может проверять и ругаться, если поставить галку:

Вопрос: Уведомление при выполнении регламентного задания

У пользователей 1С запускаются каждые 5 минут регламентные задания, стандартные в 1С8 Розница. Если осуществляется продажа и рег. задание в это время проходит, то может за двоиться продажа. Можно ли как то вывести уведомления для кассира, что запущено регламентное задание?
Ответ: ни разу с таким не сталкивался... самый простой вариант - при пробитии чека - проверять не выполняется ли в данный момент регламентное задание и по завершению - пробивать чек
и кстати, какие регламентные задания нужны на кассе? кроме обмена - не придумывается ничего..
Вопрос: Регламентные задания

(Серверный вариант базы) Есть несколько регламентных заданий, выполняющихся по расписанию, один раз в сутки, ночью....
В Общих модулях описаны процедуры, которые запускаются регламентно.
Параллельно с этим сделал из интерфейса принудительный запуск этих же процедур вручную.
Процедуры выполняют довольно сложные действия (регаментные работы по итогам трудового дня связанные с проведением документов и движениями по регистрам. Алгоритм работает верно, так как работает уже около года....
Проблема вот в чем....
Иногда. ИМЕННО ИНОГДА! Регламентное задание выполняется и прерывается аварийно по причине ошибок в проведении документов. Это происходит периодами. Может целую неделю, подряд каждый день вылетать аварийно... а может неделю продержаться нормально, без ошибок.
Парадокс в другом....
Если я запускаю все эти же процедуры вручную, принудительно, из интерфейса. Ошибок не бывает НИКОГДА.
Это что значит?
Ответ:
Ночью никто не сидит, кроме регламентных заданий.
Ваше задание лопатит документы, получает ссылку на очередной документ, затем получает по ссылке объект, а в это время другое задание уже меняет сам объект в базе.
При этом второе задание изменить объект уже не сможет - кто раньше встал - того и тапки.
Пересмотрите расписания ваших регламентных заданий, похоже они одеяло тянут - каждый на себя
Вопрос: Новое регламентное задание

В типовой Рознице 2.2, пытаюсь создать новое регламентное задание которые будет ночью будет выполняет обмен с оффлайн кассой.

Создаю регламентное задание, общий модуль для него в нем пишу для проверки соообить.
В консоли заданий смотрю что все выполняется. Но не выводится сообщение!

Ответ:
Верно, сообщить из регламентного задания подвешивает 1с. Не знаю, как с этим справляется розница, но лучше уж писать в текстовый файл или журнал регистрации
Вопрос: Справочники и Регламентное задание

Добрый день!

Столкнулся с проблемой.
Платформа 1С 8.1, База лежит на сервере MSSQL, 1С сервер x64
Есть регламентное задание которое запускается.
После запуска происходит запрос, который получив данные о некотором списке документов, анализирует данные об их контрагентах, вызывая функцию находящуюся в общем модуле этого регл. задания с параметром ссылка на контрагента.

Вот функция
Функция КонтрагентСогласен(Контрагент) Экспорт

Если Контрагент.Согласен = Истина Тогда
Возврат Истина;
иначе
Возврат Ложь;
КонецЕсли;
КонецФункции



Регламентное задание завершается с ошибкой.
Пишет что {ОбщийМодуль.Модуль()}: Метод объекта не обнаружен (Согласен)

В справочнике контрагенты, имеется реквизит типа булево, названный согласен.

Помогите советом, как совершить проверку данных из регламентного задания? Так понимаю на сервере...
Ответ:
Контрагент - ссылка на эл. справочника контрагенты.

Проблема разрешилась странным образом. В функции регламентного задания, вызывающей функцию КонтрагентСогласен(Контрагент) вместо анализа ответа от работы функции КонтрагентСогласен(Контрагент) было написано сразу

Если Контрагент.Согласен = Истина Тогда...
Вопрос: Регламентное задание "Извлечение текста"

Добрый день. Подскажите, пжл, за что отвечает регламентное задание "Извлечение текста" (есть в конфигурациях БП 3.0, УТ 11)? Можно ли его отключать?
Ответ:
Можно вообще отключить полнотестовый поиск и очистить индекс
Вопрос: Ошибка подключения к WinSCP для регламентных заданий 1С

Добрый день. Столкнулся со следующей проблемой, не получается подключиться к winSCP регламентным заданием, но при обычном запуске (например через внешнюю обработку) подключение работает корректно.
Исходные данные:
Сервер Windows server 2016
1С платформа 1С:Предприятие 8.3 (8.3.10.2299)
SQL Microsoft SQL Server 2017
WinSCP-5.11.2
Регистрировал библиотеку следующим образом:
Скопировал файл WinSCPnet.dll в папку %WINDIR%\Microsoft.NET\Framework\v4.0.30319\
И запустил команды через cmd(администратор)
%WINDIR%\Microsoft.NET\Framework\v4.0.30319\RegAsm.exe WinSCPnet.dll /codebase /tlb
//

%WINDIR%\Microsoft.NET\Framework\v4.0.30319\RegAsm.exe WinSCPnet.dll /codebase /tlb:WinSCPnet32.tlb
//

%WINDIR%\Microsoft.NET\Framework64\v4.0.30319\RegAsm.exe WinSCPnet.dll /codebase /tlb:WinSCPnet64.tlb

Но все равно в ФОНОВОМ режиме 1Ска не хочет подключаться к WinSCP.
Пишет следующую ошибку
Ошибка при вызове конструктора (COMОбъект): -2147221164(0x80040154): Класс не зарегистрирован
  
Подключаюсь следующим способом.
 sessionOptions = Новый COMОбъект("WinSCP.SessionOptions");

Буду очень рад вашей помощи. Может кто сталкивался с выгрузкой/загрузкой данных через WinSCP при помощи регламентных заданий.
Ответ: Разобрался с проблемой, поставил новую версию WinSCP. Не стал перекидывать библиотеку в папку с windows и прописал следующую команду %WINDIR%\Microsoft.NET\Framework64\v4.0.30319\RegAsm.exe "Путь до файла с новой библиотекой" /codebase /tlb:WinSCPnet64.tlb
После этого регламентные задания стали цепляться к WinSCP.
Вопрос: Запуск регламентного задания на клиенте.

Обычное приложение.
В клиент-серверном режиме работы регламентные задания запускаются на сервере. А как можно честь регламентных заданий запускать на клиенте? Есть необходимость чтобы по расписанию у определенного пользователя открывалась некая форма.
Сейчас реализовано через подключение обработчика ожидания при запуске сеанса, но это неудобно, т.к. невозможно четко расписание задать, а только интервалы между запусками.
Ответ: () Спасибо, идею понял.
Вопрос: Регламентное задание с параметром

Конфа: Комплексная автоматизация, платформа 8.3
Любопытная проблема, с некоторого времени перестало выполняться регламентное задание по обмену между базами. Если вручную обмен запустишь то все хорошо, если через регламентное задание то Ж.

Возникает ошибка "Недостаточно фактических параметров для метода фонового задания".

Само регламентное задание типовое "ВыполнениеОбмена" которое вызывает процедуру:
Код:
Процедура ВыполнитьОбменДаннымиДляНастройкиАвтоматическогоОбменаДанными(КодНастройки) Экспорт
   
   Если НЕ ЗначениеЗаполнено(КодНастройки) Тогда
     Возврат;
   КонецЕсли;
   
   НастройкаОбмена = Справочники.НастройкиВыполненияОбмена.НайтиПоКоду(КодНастройки);
   
   Если НЕ ЗначениеЗаполнено(НастройкаОбмена)
     ИЛИ НастройкаОбмена.ПометкаУдаления Тогда
     Возврат;
   КонецЕсли;
   
   ПроцедурыОбменаДанными.ВыполнитьОбменПоНастройкеАвтоматическогоВыполненияОбменаДанными(НастройкаОбмена, Ложь);
   
КонецПроцедуры
Отладка естественно невозможна, т.к. не вызывается сама по себе процедура... Поэкспериментировав с самописной тестовой базой у меня такая ошибка возникает, когда я добавляю хотя бы 1 параметр без значения по умолчанию в процедуру регламентного задания!.

Т.е. из-за параметра "КодНастройки" скорее всего и возникает данная ошибка!

Однако посмотрев большинство типовых регламентных операций я увидел что многие содержат параметр! Например:
Код:
Процедура РасчетЦеныНоменклатурыРеглЗадание(Настройка) Экспорт
Процедура ДопроведениеДокументов(Настройка) Экспорт

Через глобальный поиск узнать откуда где эти настройки вообще могут взяться ни к чему не привело. Сколько я не работал с регламентными заданиями никогда в самой вызывающей процедуре не указывал параметр...

Кто нибудь сталкивался с такой проблемой, или кто нибудь знает как типовые конфигурации умудряются указывать в объекте метаданных "Регламентные задания" процедуру с параметром?

Например в конфе бухгалтерия 3.0 есть регламентное задание "ЗапускДополнительныхОбработок" которая вызывает процедуру с 2 параметрами:
Код:
Процедура ВыполнитьОбработкуПоРегламентномуЗаданию(ВнешняяОбработка, ИдентификаторКоманды) Экспорт...
Ответ:
Дружище! Спасибо тебе огромное за помощь, сделал как ты сказал, заработало.
Ниже прикладываю модифицированную для решения этой проблемы обработку консоли задач, может кому пригодиться.

Вложения:

  • Размер файла:
    33,7 КБ
    Просмотров:
    9
Вопрос: Можно ли переименовать процесс регламентного задания в 1с 8?

Нужно с помощью скрипта определять, запущены ли регламентные задания в отдельном сеансе, если нет, то им выводится предупреждение и нам на почту уходит сообщение. Но т.к. у 1с и регламентного задания процессы одинаковые, то нет возможности определить, запущены ли регламентные задания. Чтобы определить, нужно, чтобы процесс назывался как то по другому. Возможно ли такое сделать?
Ответ: Если с 1с туго.
Можно ещё писать регзаданием что-то на диск и скриптом проверять дату у файлика.