Все технические форумы на одном сайте Удобный поиск информации с популярных форумов в одном месте
Вопрос: классификатор палитра цветов

Всем доброго дня.
Подскажите есть такой классификатор цветов для справочников, и где его грузить если есть.
Ответ: () а смысл?
надо тогда отдельный справочник цветов создавать.
Вопрос: Диалог выбора цвета

Всем привет, кто как реализует диалог выбора цвета? (необходима палитра)

в теории есть такие варианты:
- новый ДиалогВыбораЦвета; (палитра цветов отсутствует, по этому не подходит)
- через ПолеHTMLДокумента (html + js + css) (требует дополнительных настроек на пользовательском компе) 
- Подключить что нибудь сторонне например через ActiveX (требует установки чего то на пользовательском компе)
- костыль, через ПолеТабличногоДокумента (создать градиент rgb и рядом все оттенки выбранного цвета, аналог палитры цветов) решение кривое согласен, но это единственное что работает "из коробки" без настроек ie разрешать js и т.д. и установки чего то дополнительного
- в одной конфигурации Раруса видел диалог выбора цвета, вызывался стандартным методом "новый ДиалогВыбораЦвета", но он открывался с палитрой цветов, как они это реализовали, так и не понял.


Давайте коллективным умом создадим человеческий выбор цвета через палитру цветов?
Ответ: () () прошу прощения, не так прочитал, я и использую 2 табдока. один фиксируется, а второй нет
Вопрос: Задать цвет ячейки Excel из 1с

Была тема, но ответа не нашел в ней.


Решил перебрать коды цветов от 1 до 2 000 000, получился файлик

Нету в нем много много нужных цветов.
Показалось что чередуются коды от 1 до 65535.
Может кто знает как задать цвет ячейки, например светлосерый или бледно розовый и тд.
Ответ: В Excel 2003 в цветами проблема.
Есть определенный перечень цветов, его можно заполнить разными цветами, и потом из этого набора только можно разукрасить ячейки по коду ячейки :(
Если пере разукрасить предопределенные цвета , то и в таблице ячейки изменят цвет.
В настройках не нашел как непосредственно использовать цвета из полной палитры.
Может кто знает?
Вопрос: Классификатор стран мира - не настроить синхронизацию

Подскажите плз.
Синхронизация
"Управление торговлей", редакция 10.3 (10.3.33.1)

Бухгалтерия предприятия (базовая), редакция 3.0 (3.0.43.137)

Прямое подключение к базе
Не выгружается справочник "Классификатор стран мира"


Отчет:
Состав отправляемых данных*

№ п/п Данные Выбрано Не будет отправлено Всего объектов в базе
По общим правилам Дополнительно Будет отправлено
1 Адресные сокращения 154 - 154 - 154
2 Классификатор стран мира - 48 - 48 48
3 Контрагенты 5 - 5 463 468
Итого 159 48 159 511 670



* В состав отправляемых данных могут быть включены дополнительные объекты для обеспечения целостности данных

Правила синхронизации данных
"Выгружать документы и справочную информацию:
Выгружатется аналитика по складам
Себестоимость списания товаров, не переносится
Документы выгружаются начиная с 1 января 2016 г.
Документы выгружаются только отраженные в бухгалтерском учете

По всем организациям
По всем складам
По всем подразделениям"

Добавленные дополнительно данные
Классификатор стран мира: Все объекты

Подскажите, где что подправить, чтобы справочник выгружался.
Правила конвертации данных для справочника:
			<Правило>
				<Код>КлассификаторСтранМира</Код>
				<Наименование>Справочник: Классификатор стран мира</Наименование>
				<Порядок>400</Порядок>
				<СинхронизироватьПоИдентификатору>true</СинхронизироватьПоИдентификатору>
				<ПродолжитьПоискПоПолямПоискаЕслиПоИдентификаторуНеНашли>true</ПродолжитьПоискПоПолямПоискаЕслиПоИдентификаторуНеНашли>
				<ИспользоватьБыстрыйПоискПриЗагрузке>true</ИспользоватьБыстрыйПоискПриЗагрузке>
				<ГенерироватьНовыйНомерИлиКодЕслиНеУказан>true</ГенерироватьНовыйНомерИлиКодЕслиНеУказан>
				<Источник>СправочникСсылка.КлассификаторСтранМира</Источник>
				<Приемник>СправочникСсылка.СтраныМира</Приемник>
				<Свойства>
					<Свойство>
						<Код>1</Код>
						<Наименование>ПометкаУдаления --&gt; ПометкаУдаления</Наименование>
						<Порядок>100</Порядок>
						<Источник Имя="ПометкаУдаления" Вид="Свойство" Тип="Булево"/>
						<Приемник Имя="ПометкаУдаления" Вид="Свойство" Тип="Булево"/>
					</Свойство>
					<Свойство Поиск="true">
						<Код>2</Код>
						<Наименование>Код --&gt; Код</Наименование>
						<Порядок>200</Порядок>
						<Источник Имя="Код" Вид="Свойство" Тип="Строка"/>
						<Приемник Имя="Код" Вид="Свойство" Тип="Строка"/>
					</Свойство>
					<Свойство>
						<Код>3</Код>
						<Наименование>Наименование --&gt; Наименование</Наименование>
						<Порядок>300</Порядок>
						<Источник Имя="Наименование" Вид="Свойство" Тип="Строка"/>
						<Приемник Имя="Наименование" Вид="Свойство" Тип="Строка"/>
					</Свойство>
					<Свойство>
						<Код>4</Код>
						<Наименование>НаименованиеПолное --&gt; НаименованиеПолное</Наименование>
						<Порядок>400</Порядок>
						<Источник Имя="НаименованиеПолное" Вид="Реквизит" Тип="Строка"/>
						<Приемник Имя="НаименованиеПолное" Вид="Реквизит" Тип="Строка"/>
					</Свойство>
					<Свойство>
						<Код>5</Код>
						<Наименование>КодАльфа2 --&gt; КодАльфа2</Наименование>
						<Порядок>450</Порядок>
						<Источник Имя="КодАльфа2" Вид="Реквизит" Тип="Строка"/>
						<Приемник Имя="КодАльфа2" Вид="Реквизит" Тип="Строка"/>
					</Свойство>
				</Свойства>
				<Значения/>
			</Правило>

			<Правило Отключить="false">
				<Код>КлассификаторСтранМира</Код>
				<Наименование>Справочник: Классификатор стран мира</Наименование>
				<Порядок>5200</Порядок>
				<КодПравилаКонвертации>КлассификаторСтранМира                            </КодПравилаКонвертации>
				<СпособОтбораДанных>СтандартнаяВыборка</СпособОтбораДанных>
				<ОбъектВыборки>СправочникСсылка.КлассификаторСтранМира</ОбъектВыборки>
			</Правило>
Ответ: Перекапала полкода...
Если в справочнике "Классификатор стран мира" разрешить авторегистрацию для этого плана обмена, то страны выгружаются. Я их вижу в файле. Но в БП они так и не подгружаются при этом :(
Вопрос: Хранение цвета в реквизите справочника

Добрый день
Подскажите как сохранить цвет в реквизите справочника?
кроме как 3 реквизитов R,G,B в голову ничего не лезет

PS
Идея в том,что бы пользователь указывал цвет элемента справочника,и потом отчет раскрашивался в этот цвет.
Ответ: () пример чего?
получи R,G,B от цвета с типом Цвет
Вопрос: Цвет состояния заказа

В табл части внешней обработки есть реквизит Состояние это СправочникСсылка.СостоянияЗаказовПокупателей, у справочника есть реквизит Цвет - ХранилищеЗначений.
Как раскрасить Состояние согласно Цвета?
Ответ: ниче не сложно
очень помогло, что одно из состояний было предопределенным и я задала условное оформление Формы.
Потом ЭтотОбъект.УсловноеОформление.Элементы[0]
    ЦветСостояния = ВыборкаДетальныеЗаписи.Цвет.Получить();
        Если ТипЗнч(ЦветСостояния) <> Тип("Цвет") Тогда
            Продолжить;
        КонецЕсли;
        Номерс = Номерс + 1;
        ЭлементУсловногоОформления = ЭтаФорма.УсловноеОформление.Элементы.Добавить();
        
        ЭлементУсловногоОформления.Оформление.УстановитьЗначениеПараметра("ЦветТекста", ЦветСостояния);
        ЭлементУсловногоОформления.ИдентификаторПользовательскойНастройки = "ЦветСостояния" + Номерс;
        ЭлементУсловногоОформления.РежимОтображения    = РежимОтображенияЭлементаНастройкиКомпоновкиДанных.БыстрыйДоступ;
        ЭлементУсловногоОформления.Представление    = НСтр("ru='Оформление в цвет состояния'" + Номерс);
        
        ЭлементОтбора = ЭлементУсловногоОформления.Отбор.Элементы.Добавить(Тип("ЭлементОтбораКомпоновкиДанных"));
        ЭлементОтбора.ЛевоеЗначение        = Новый ПолеКомпоновкиДанных("Объект.ЗаказыНаДату.Состояние");
        ЭлементОтбора.ВидСравнения        = ВидСравненияКомпоновкиДанных.Равно;
        ЭлементОтбора.ПравоеЗначение    = ВыборкаДетальныеЗаписи.Ссылка;
        ПолеОформления = ЭлементУсловногоОформления.Поля.Элементы.Добавить();
        ПолеОформления.Поле = Новый ПолеКомпоновкиДанных("ЗаказыНаДатуСостояние");
        ПолеОформления.Использование = Истина;
Тут обязательно указать ПОЛЕ оформления, без него не получилось
Вопрос: Поменять цвет текста

добрый ночи. У меня такой вопрос как поменять цвет текста. Этот текст создается программной и записывается в форму, но мне нужно поменять цвет определенного слова,
что бы было легче читать его, а не всей формы.
Ответ:
Можно через БСП, можно ручками 



&НаСервере
Функция ФорматСтрокаБСП()
    
    //Элементы стиля: ЦветБаннераБежевый   , ЦветБаннераЗеленый, ЦветГиперссылкиБРО       ЦветУспешнойОперацииГосИС

    
    Возврат  СтроковыеФункции.ФорматированнаяСтрока(                        
    
    НСтр("ru='<span style=""color: ЦветГрадацияСПАРКВысокийРиск"">Х</span><span style=""color: ЦветУспешнойОперацииГосИС"">У</span><span style=""color:ЦветГиперссылкиБРО"">Ц</span>'")    
    );

    
Конецфункции

&НаКлиенте
Процедура ПриОткрытии(Отказ)

    Элементы.Декорация1.Заголовок = ФорматСтрокаБСП();    
    
МассЧастей = Новый Массив;
МассЧастей.Добавить(Новый ФорматированнаяСтрока("К", , Новый Цвет(255, 0, 0)));
МассЧастей.Добавить(Новый ФорматированнаяСтрока("У", , Новый Цвет(0, 255, 0)));
МассЧастей.Добавить(Новый ФорматированнаяСтрока("Й", , Новый Цвет(0, 0, 255)));

                               
    Элементы.Декорация2.Заголовок = Новый ФорматированнаяСтрока(МассЧастей);
КонецПроцедуры
Вопрос: Выделить задолженность красным цветов

Здравствуйте!
Отчет на СКД по регистру взаиморасчетов с контрагентами.
Стандартные ресурсы: Начальный остаток, Приход, Расход и Конечный остаток.
Мне надо красным цветом выделять неоплаченные продажи, т.е. те строки, где конечный остаток больше нуля.
Но сложность в том, если за период отбора попали документы, где на определенную дату конечный остаток = 0, то все документы до этой даты считаются оплаченными и их красным выделять не надо.
На картинке показано как надо сделать.
Только я не могу сообразить как
Ответ:
Спасибо!
Да, сделала ещё дополнительную выборку последней даты, где конечный остаток равен 0. И по ней прописала условие:
Если Конечный остаток > 0 и Период > ПоследняяДатаНулевогоОстатка Тогда Красный цвет!
Вопрос: Как в панели навигации оформить ссылку красным цветом?

Как в панели навигации оформить ссылку красным цветом?

Ответ:
Ну и что тогда было воду мутить? Человек спросил "оформить ссылку красным цветом", а не ссылки.
Вопрос: Изменить цвет текущей строки по кнопке

Можно ли изменить цвет текущей строки в табличной части по кнопке?

Делал так, но это не совсем то
1C
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
&НаКлиенте
Процедура СделатьПодарок(Команда)
    
    ТекущиеДанные = Элементы.Запасы.ТекущиеДанные;
        
    Если ТекущиеДанные = Неопределено Тогда
        Сообщить("Не выбрана строка");
        Возврат;
    КонецЕсли;  
    
    ТекущиеДанные.Цена = 0;
    ТекущиеДанные.Сумма = 0;
    
    СделатьПод();
            
КонецПроцедуры
 
&НаСервере
Процедура СделатьПод()
    
    ЭтаФорма.УсловноеОформление.Элементы.Очистить();
    ЭлементУсловногоОформления = УсловноеОформление.Элементы.Добавить();
    ОформляемоеПоле = ЭлементУсловногоОформления.Поля.Элементы.Добавить();
    ОформляемоеПоле.Поле = Новый ПолеКомпоновкиДанных("Запасы");
    ЭлементОтбора = ЭлементУсловногоОформления.Отбор.Элементы.Добавить(Тип("ЭлементОтбораКомпоновкиДанных"));
    ЭлементОтбора.ЛевоеЗначение = Новый ПолеКомпоновкиДанных("Объект.Запасы.Цена");
    ЭлементОтбора.ВидСравнения = ВидСравненияКомпоновкиДанных.Меньше;
    ЭлементОтбора.ПравоеЗначение = 1;
    ЭлементУсловногоОформления.Оформление.УстановитьЗначениеПараметра("ЦветТекста", WebЦвета.Зеленый);
 
    
КонецПроцедуры
Ответ: Добавь колонку ФлагЦветаСтроки (например тип число)

Добавь условное оформление
Цвет синий - Условие: ФлагЦветаСтроки = 1

1C
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
&НаКлиенте
Процедура СделатьПодарок(Команда)
    
    ТекущиеДанные = Элементы.Запасы.ТекущиеДанные;
        
    Если ТекущиеДанные = Неопределено Тогда
        Сообщить("Не выбрана строка");
        Возврат;
    КонецЕсли; 
 
    ТекущиеДанные.ФлагЦветаСтроки  = 1;
    
 
            
КонецПроцедуры